Search for at
Security Code:
Security Code 
Type Security Code:
EVO CMS Advanced Search
 
 
Recent Topics
Latest Site News << Previous 5  Next 5 >>
Forum Author Replies Last Post
Great !  Blau.de bietet mobile Datenflatrate für 20 Euro an News & Informationen Spiders 6 29 Jan 2009
Spiders View latest post
Roleplay  Keine dauerhaften Prüfpflichten bei Links News & Informationen Spiders 0 25 Jan 2009
Spiders View latest post
solved  chiroptera zeitweise ausser Betrieb News & Informationen chiroptera 14 27 Nov 2008
Thorm View latest post
Warning !  Einführung des Begriffs Template ab Evo 2.1.0 Release News & Informationen Spiders 1 26 Nov 2008
linus78 View latest post
fixed  Eingeschränkter Support News & Informationen chiroptera 0 24 Nov 2008
chiroptera View latest post
Recent Topics << Previous 15  Next 15 >>
Forum Author Replies Last Post
under work  Nach aussperren: SQL Fehler Fehlermeldungen 1.02.GER Scourge 4 22 Apr 2009
Scourge View latest post
No icon  News Probleme, bitte um Schnelle hilfe Allgemeines Fatal 1 22 Apr 2009
ReOrGaNiSaTiOn View latest post
under work  Cronjob Allgemeines tgermanyx 9 22 Apr 2009
ReOrGaNiSaTiOn View latest post
No icon  SQL Table creation error Support German Community Wonderbugg 4 22 Apr 2009
GANYANCI View latest post
No icon  MSAnalysis für evo 210 steht zum download bereit Module Guest 8 21 Apr 2009
GuestView latest post
No icon  Downloadmodul verweigert Dienst Fehlermeldungen 2.1.0 RC Chris 25 20 Apr 2009
RTC4EVER View latest post
Question  Probleme auf der Page Fehlermeldungen 2.1.0 RC Shiggy 1 20 Apr 2009
Spiders View latest post
Idea  Unglaublicher Umbau: Ein C64 wird zum Notebook ChitChat Spiders 1 20 Apr 2009
Thorm View latest post
under work  Hilfe nach Installation!! Fehlermeldungen 2.1.0 BETA Shiggy 9 19 Apr 2009
Spiders View latest post
under work  Passwort ändern? Fehlermeldungen 1.02.GER Chako 37 19 Apr 2009
Spiders View latest post
under work  Mehrere verschiedene URL's möglich??? Fehlermeldungen 2.1.0 RC Greifi 8 16 Apr 2009
GuestView latest post
No icon  keine Grafiken werden angezeigt Fragen & Hilfe zur Installation/Upgrade 2.1.x vampirlord 11 16 Apr 2009
vampirlord View latest post
No icon  Webhoster als Virenschleuder? Webhosting Shark 5 15 Apr 2009
Second View latest post
under work  SQL-Fehler bei Spiele aufrufen Module legolas 7 15 Apr 2009
Pitbull26 View latest post
Warning !  Frage in beziehung änderungen Forenmodul im RC3 Mods Guest 3 15 Apr 2009
GuestView latest post
 

 
Downloadmodul verweigert Dienst
 Goto page 1, 2  Next
 
This forum is locked: you cannot post, reply to, or edit topics. This topic is locked: you cannot edit posts or make replies. printer-friendly view
View previous topic :: View next topic  
Author Message
Chris
EVO User
EVO User



Joined: 03-Jan-2006
Posts: 231
Location: Bedernau
Offline
EVO Version: Nuke-Evolution 2.10 RC4 Rev761
Post Posted:
 12 Jan 2009
Reply with quote
Post subject: No icon Downloadmodul verweigert Dienst

Wenn ich im Download- Modul etwas Uploade wird es erfolgreich eingetragen. Wenn der User das File dann Downloaden möchte heißt es:

Eine URL für den Download ist sehr wichtig
Bitte gehe zurück und ergänze es


Wenn ich dann das File im Adminbereich des Download- Moduls nachsehe steht unter Download URL: nichts drin.
Ich gebe also nun die URL ein bzw. den Ordner wo das Modul es rauf geladen hat meines Webspace. Nach dem Speichern kommt die Meldung:

Eine URL für den Download ist sehr wichtig
Bitte gehe zurück und ergänze es
oder
Die in der URL angegebene Datei existiert auf Deinem Server nicht.


Das die hinzugefügte URL funktioniert weis ich da ich es direkt im Browser getestet habe als Adresse und als Download-File dann auch angeboten wird.

Wo ist nun der Haken, oder ein Bug?  


 


Last edited by Chris on 12 Jan 2009; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
chiroptera
Administrator
Administrator



Joined: 15-Feb-2006
Posts: 7808
Location: Berlin
Offline
EVO Version: 2.1.0 Developer
Post Posted:
 12 Jan 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Wenn ich mal aus den Release Notes zitieren darf:
Quote:
Bekannte Bugs, die wir leider in der aktuellen RC1 noch nicht beheben konnten:
- Download Modul Administration: Hier ist die Freigabe und die Bearbeitung von eingereichten Downloads noch nicht ganz fertig. Dazu ist die Userprüfung (Uploads/'Downloads) noch nicht vollständig abgeschlossen.

Reo ist aber dran das Download Modul fertig zu stellen smile  


 
 
Back to top
View user's profile Send private message
Chris
EVO User
EVO User



Joined: 03-Jan-2006
Posts: 231
Location: Bedernau
Offline
EVO Version: Nuke-Evolution 2.10 RC4 Rev761
Post Posted:
 12 Jan 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

ok, danke.  


 
 
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
RTC4EVER
Coding Expert
Coding Expert



Joined: 04-Feb-2009
Posts: 923
Location: Zürich
Offline
EVO Version: 2.1.0 Final
Post Posted:
 05 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

ist es mit RC2 shon fertig gestellt?  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Spiders
EVO World Team
EVO World Team



Joined: 13-Mar-2006
Posts: 3877
Location: Aachen
Offline
Post Posted:
 05 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

jepp , das Download Modul sollte funktionieren.

Gruß
Spiders  


 
 
Back to top
View user's profile Send private message Visit poster's website
Acrot
EVO User
EVO User



Joined: 17-Jun-2007
Posts: 47
 
Offline
EVO Version: 2.1.0RC2
Post Posted:
 05 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Download-Modul:

hier erhalte ich eine Fehlermeldung, wenn ich einen Download hinzufügen möchte über die Administration.

Quote:
Fatal error: Call to undefined function downloadslinkcheck() in /users/gol/www/modules/Downloads/admin/AddNewDownloadS.php on line 96
 


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 05 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Hi,

das ist ein Fehler des RC1. Bist Du sicher, dass Du alle Dateien überschieben hast beim Upload ?  


 
 
Back to top
View user's profile Send private message Visit poster's website
Acrot
EVO User
EVO User



Joined: 17-Jun-2007
Posts: 47
 
Offline
EVO Version: 2.1.0RC2
Post Posted:
 06 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

ReOrGaNiSaTiOn wrote (View Post):
Hi,

das ist ein Fehler des RC1. Bist Du sicher, dass Du alle Dateien überschieben hast beim Upload ?


Ja, da bin ich mir sicher, ich habe auch noch eine reine Neuinstallation mit der RC2 gemacht und auch dort erhalte ich diese Fehlermeldung.  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 06 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Mmmh ... komisch ... ich habe das eben geprüft. Stimmt.

Datei:  modules/Downloads/admin/functions.php

Ersetze  function DownloadLinkCheck(
mit        function DownloadsLinkCheck(

Sorry ....  


 
 
Back to top
View user's profile Send private message Visit poster's website
Acrot
EVO User
EVO User



Joined: 17-Jun-2007
Posts: 47
 
Offline
EVO Version: 2.1.0RC2
Post Posted:
 06 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Danke Reo ... das hinzufügen des Downloads geht nun ... aber wenn ich versuche die Datei herunterzuladen, geht es gleich weiter. Er versucht dann eine Datei mit dem Namen modules.php.zip zu laden obwohl die Datei einen anderen Namen hat.

Es gibt auch eine Fehlermeldung im Adminbereich ... siehe Anhang. Dies ist bei der Homepage wo ich das Update gemacht habe.

Bei der Seite wo ich die Neu-Installation gemacht habe bekomme ich allerdings folgende Fehlermeldung:

Quote:
Der angegebene Server konnte nicht erreicht werden (1)


wenn ich den Download hinzufügen möchte, dort gibt es dann aber auch keine Fehlermeldung im Protokoll.  Razz  


 
 
Back to top
View user's profile Send private message Visit poster's website
chiroptera
Administrator
Administrator



Joined: 15-Feb-2006
Posts: 7808
Location: Berlin
Offline
EVO Version: 2.1.0 Developer
Post Posted:
 06 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Mad  ... hab' gerade mal geschaut ... die Tabelle wird bei Installation überhaupt nicht angelegt.  Embarassed
Wird schnellst möglich nachgereicht.

Gruß
chiroptera  


 
 
Back to top
View user's profile Send private message
Acrot
EVO User
EVO User



Joined: 17-Jun-2007
Posts: 47
 
Offline
EVO Version: 2.1.0RC2
Post Posted:
 06 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

ReOrGaNiSaTiOn wrote (View Post):
Mmmh ... komisch ... ich habe das eben geprüft. Stimmt.

Datei:  modules/Downloads/admin/functions.php

Ersetze  function DownloadLinkCheck(
mit        function DownloadsLinkCheck(

Sorry ....


Wie ich eben bemerkte ist das gleiche auch bei

Datei: modules/Downloads/admin/DownloadsValidate.php

nötig.  Winken  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 06 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Yepp Acrot ... das war aber auch die einzige, die noch nicht umgestellt war.  


 
 
Back to top
View user's profile Send private message Visit poster's website
RTC4EVER
Coding Expert
Coding Expert



Joined: 04-Feb-2009
Posts: 923
Location: Zürich
Offline
EVO Version: 2.1.0 Final
Post Posted:
 10 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Well i have the rc2 installed and changed the admin/functions.php and the admin/DownloadsValidate.php as u sayd above.

If u had a download via admin than it's possible to download very well but if u had a download via public, it shows the same error.  "The Host specified in your URL could not be found."

Any more changes??  


 


Last edited by RTC4EVER on 10 Feb 2009; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
RTC4EVER
Coding Expert
Coding Expert



Joined: 04-Feb-2009
Posts: 923
Location: Zürich
Offline
EVO Version: 2.1.0 Final
Post Posted:
 10 Feb 2009
Reply with quote
Post subject: No icon Re: Downloadmodul verweigert Dienst

Another error i could find on adding a new download via admin was on line 485 admin/functions.php

just changed

$forbidden_list = DownloadsAllowedExtensions();

for

$forbidden_list = DownloadAllowedExtensions();$

removing the "s" between Download and Allowed..

Houpe i'm not wrong ReO  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:  
This forum is locked: you cannot post, reply to, or edit topics. This topic is locked: you cannot edit posts or make replies. printer-friendly view
EVO CMS Forum Index -> Fehlermeldungen 2.1.0 RC Time synchronized with the forum server time
 Goto page 1, 2  Next
Page 1 of 2


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum