Search for at
Security Code:
Security Code 
Type Security Code:
EVO CMS Advanced Search
 
 
Recent Topics
Latest Site News   Next 5 >>
Forum Author Replies Last Post
fixed  Frage nach JavaScript aktiv oder nicht? Fixes & Patches 2.1.x Guest 8 30 Mar 2013
GuestView latest post
fixed  [FIX 2.1.0] Lost Password Fixes & Patches 2.1.x chiroptera 0 21 Feb 2012
chiroptera View latest post
fixed  [FIX 2.1.0] Forums ACP - FAQ Admin Fixes & Patches 2.1.x chiroptera 1 27 Oct 2011
chiroptera View latest post
fixed  [FIX 2.1.0] Forums Attachment Image Resize Fixes & Patches 2.1.x chiroptera 0 26 Oct 2011
chiroptera View latest post
Important  [INFO] evo-mods service started News & Informationen chiroptera 2 24 Oct 2011
chiroptera View latest post
Recent Topics   Next 15 >>
Forum Author Replies Last Post
Important  Wünsch Dir was für die 2.1.1 EVO-CMS 2.x.x Guest 126 09 Jan 2015
GuestView latest post
Important  Website Awards Eure Webseiten chiroptera 42 01 Aug 2013
GuestView latest post
Achtung  EVO Maps does not work any longer Fehlermeldungen chiroptera 0 06 Mar 2012
chiroptera View latest post
Idea  Webhoster Testseite Webhosting Thorm 16 16 Nov 2011
Hepher View latest post
No icon  links ChitChat pd35 0 29 Apr 2016
pd35 View latest post
No icon  Ideal Web Design Company ChitChat kate12 0 26 Feb 2016
kate12 View latest post
No icon  Schwerer Fehler bei der Installation Fragen & Hilfe vor der Installation 2.1.x mglobig 4 25 Jul 2015
der-cyberwolf View latest post
No icon  [Module][Anfrage] An-Ausschalten der Linken Rechten Seite Fragen und Antworten / Questions and Answers blaubirne 0 19 Apr 2015
blaubirne View latest post
Important  USA: nuke-evolution --> evolution-xtreme // EVO-German EVO-CMS 2.x.x Guest 10 24 Nov 2014
der-cyberwolf View latest post
No icon  Gruppenbefugnisse Fehlermeldungen 2.1.0 Maiki 0 09 Dec 2013
Maiki View latest post
No icon  Wie ein Fels... ChitChat Anna 2 19 Nov 2013
GuestView latest post
No icon  Adminpasswort vergessen Support German Community Second 5 27 Sep 2013
Second View latest post
No icon  PHP Version 5.4.4-14+deb7u2 Fehlermeldungen 2.1.0 Maiki 10 26 Jul 2013
GuestView latest post
solved  Forum - Anzeige zuletzt bearbeitet Fehlermeldungen 2.1.0 Anna 18 12 May 2013
Anna View latest post
No icon  Ein frohes Weihnachtsfest 2011 & Wünsche ChitChat Guest 12 24 Dec 2012
nedkelly View latest post
 

 
Beförderter Admin kommt nicht auf admin.php
 Goto page 1, 2  Next
 
This forum is locked: you cannot post, reply to, or edit topics. This topic is locked: you cannot edit posts or make replies. printer-friendly view
View previous topic :: View next topic  
Author Message
Entenmann
EVO User
EVO User



Joined: 03-Jan-2007
Posts: 144
Location: Waltershausen
Offline
EVO Version: 2.1.0 Basic Build:2028
Post Posted:
 29 Jun 2009
Reply with quote
Post subject: solved Beförderter Admin kommt nicht auf admin.php

Hallo,

wenn ich einen User zum Admin beförder, bekommt er trotz allem den Adminbereich nicht angezeigt.

Selbst wenn er sich erst normal anmeldet und dann versucht die admin.php aufzurufen kann er sich nicht einlogen.

Auch eine beförderung zum Superadmin bringt keinen Erfolg.

Normal sollten alle Admins den Adminblock angezeigt bekommen, was auch nicht funktioniert.

Mit dem beider Installation angelegtem Admin klappt alles ohne Probleme.

Allerdings müssen seine News selbst als Superuser  immernoch bestädigt werden anstatt sofort veröffentlicht zu werden

Gruß
René  


 


Last edited by Entenmann on 01 Jul 2009; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
chiroptera
Administrator
Administrator



Joined: 15-Feb-2006
Posts: 7808
Location: Berlin
Offline
EVO Version: 2.1.0 Developer
Post Posted:
 29 Jun 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Was heißt "bekommt den Adminbereich nicht angezeigt"? Eintragungen im Admin Log oder im Error Log?

Gruß
chiroptera

Edit: Schon gelesen? ->
Please login to see this link
Get registered or Log in
 


 
 
Back to top
View user's profile Send private message
Entenmann
EVO User
EVO User



Joined: 03-Jan-2007
Posts: 144
Location: Waltershausen
Offline
EVO Version: 2.1.0 Basic Build:2028
Post Posted:
 29 Jun 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Hallo chirpotera,

das wiki ist mir bekann. Im Adminerrorlog sind dann volgende Einträge:

wenn ich gleich auf die Admin.php gehe

Quote:
---------[Security Breach]------------------------------------------------------------------------------------------------------------
- [29 Jun 2009 - 12:02:41] -
User: Anonym
IP: 194.25.112.132

Attempted to login with "mein Benutzernam"/"mein Passwort" but failed
---------------------------------------------------------------------------------------------------------------------------------------
 


wenn ich mich vorher auf der Seite anmelde:


Quote:

---------[Security Breach]------------------------------------------------------------------------------------------------------------
- [29 Jun 2009 - 12:02:41] -
User: mein Username
IP: 194.25.112.132

Attempted to login with "mein Username"/"mein Passwort" but failed
---------------------------------------------------------------------------------------------------------------------------------------


Habe den richtigen Username und passwort unkenntlich gemacht!

Normal sollte ich doch schon bei der normalen Anmeldung den Adminblock mit angezeigt bekommen?

Gruß
René  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 29 Jun 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Hi,

ich gehe davon aus, dass Du selbst versucht hast mit dem Usernamen/Passwort eine Anmeldung zu machen ?
HAst Du zuvor Deine Cookies gelöscht bzw. Dich als Admin abgemeldet ?

Ich kann mich daran erinnern, dass es noch ein Problem gab, das ich aber behoben habe. Glaub kiste0406 müsste etwas dazu sagen können.

Grüsse
Reo  


 
 
Back to top
View user's profile Send private message Visit poster's website
Entenmann
EVO User
EVO User



Joined: 03-Jan-2007
Posts: 144
Location: Waltershausen
Offline
EVO Version: 2.1.0 Basic Build:2028
Post Posted:
 29 Jun 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Hallo Reo,

ich habe alles probiert, Cookies löschen etc. Keine Besserung. Schlecht  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Entenmann
EVO User
EVO User



Joined: 03-Jan-2007
Posts: 144
Location: Waltershausen
Offline
EVO Version: 2.1.0 Basic Build:2028
Post Posted:
 01 Jul 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Hallo,

ich habe des Problemes übel gefunden.

Ich hatte schonmal einen Benutzer mit dem Namen. Nach dem löschen ist aber nur sein name aus der Tabelle evo_user gelöscht worden und nicht der ganze Eintrag.

Wird der Benutzer jetzt nochmal mit dem gleichen Namen angelegt, erscheint ein neuer eintrag mit Benutzername in der Tabelle. Jedoch scheint da etwas mit dem alten leeren Eintrag zu kollidieren.

Wird der User dann zum Admin befördert erscheint er zwar als Admin hat aber die Rechte nicht.

Jetzt habe ich den Benutzer erneut gelöscht. In der Tabelle users war wieder nur der Name entfernt und nicht der ganze Eintrag. Auch unter authors war er noch eingetragen.

Erst ein löschen beider Tabelleneinträge per Hand brachte den Erfolg. Benutzer neu angelegt und beförder und es haut hin.

Gruß

René  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Entenmann
EVO User
EVO User



Joined: 03-Jan-2007
Posts: 144
Location: Waltershausen
Offline
EVO Version: 2.1.0 Basic Build:2028
Post Posted:
 01 Jul 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Sorry, wenn ich das nochmal noch oben bringe.

Ich habe gerade festgestellt, das nach dem löschen irgendwo noch die user_id des Nutzers in der Tabelle bleibt.

Wenn man dann in der Forumsadministration die Gruppen verwalten will ist das nicht möglich.

War der User mod oder Admin spielt die ganze Gruppenverwaltung verrückt, da immer noch eine abfrage nach der user_id erfolgt.

Meine Notlösung: in der tabelle einen toten user die alte ID zuteilen. wie bekomme ich den dann sauber aus dem System?

Gruß
René  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
TODIMO
EVO User
EVO User



Joined: 17-Jan-2006
Posts: 202
 
Offline
Post Posted:
 20 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Muss den Thread nochmal hochholen.

Habe nämlich das gleiche Problem.
Der Trainer soll "eingeschränkten Adminzugriff" bekommen. Habe ihn deshalb befördert.
Leider kann er sich nicht einloggen.

Habe die üblichen Cachespiel mit ihm schon angearbeitet - Ohne erfolg.

Muss dazu sagen das ich vorher die 1.02. installiert hatte und einfach die DB evo_user übernommen haben in die 2.1. da für mich als Nob kein Unterschied erkennbar war und ich somit meine 5 User übernehmen konnte.  


 
 
Back to top
View user's profile Send private message
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 20 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Öhm .... WIE hast Du den User befördert ?  


 
 
Back to top
View user's profile Send private message Visit poster's website
TODIMO
EVO User
EVO User



Joined: 17-Jan-2006
Posts: 202
 
Offline
Post Posted:
 20 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Im Bereich "Benutzer Administration - Mitglied befördern" habe ich den trainer ausgewählt und ihm Berechtigungen für einzelne Module gegeben.
Hatte eben bei einer meiner Testinstallationen das ganze auch gemacht mit testAccounts da verlief es problemlos. Vermute liegt am Übertrag der "alten DB" auf die 2.1.

Aber ich habe jetzt beschlossen - ich warte ein paar Tage bis zur Freigabe der nächsten Rev. dann gibts eine saubere neue Installation und meine 4 User solln sich neu anmelden.  


 
 
Back to top
View user's profile Send private message
Guest
 





 
Offline
Post Posted:
 20 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Da möchte ich mich gern einklinken...

Hab meinen einzigen User auf der Testseite (REV 725) auch befördert, analog wie todimo, als Admin testweise für das Download-Modul.

Nachdem Befördern bekomme ich die Meldung:
Benutzer wurde dem Admin avanciert. -> Vielleicht sollten wir die Meldung ändern, da ja der oder die Admin(s) nur befördern können.

Der Webmaster (Admin) bekommt eine Mail, wo leider in der dt. Sprachdatei noch zwei Einträge fehlen.
im Header der Mail steht: _ACCTPROMOTE
im Mailtext steht: Dein Benutzerkonto bei Meine Test-Seite _HASPROMOTE

Und jetzt das Interessante, was ich unter der 725 feststellen konnte, mein User kann sich mit seinen Daten als Admin einloggen, er bekommt das Modul DL für die Administration zu sehen, aber auch die Meldung: FEHLER - Du hast keine Administrationsrechte für das Modul
Wenn der User jetzt auf das Symbol des DL klickt, kann er das Download-Modul administrieren und auch Veränderungen abspeichern.  


 
 
Back to top
View user's profile Send private message
RTC4EVER
Coding Expert
Coding Expert



Joined: 04-Feb-2009
Posts: 923
Location: Zürich
Offline
EVO Version: 2.1.0 Final
Post Posted:
 21 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

_ACCTPROMOTE
added to modules/Your_Account/language as 'define("_ACCTPROMOTE", "You Have Just Been Promoted!");'

_HASPROMOTE
added to modules/Your_Account/language as 'define("_HASPROMOTE","has been promoted.");'  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 21 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

ok ... Sprachfiles wurden geändert.  


 
 
Back to top
View user's profile Send private message Visit poster's website
RTC4EVER
Coding Expert
Coding Expert



Joined: 04-Feb-2009
Posts: 923
Location: Zürich
Offline
EVO Version: 2.1.0 Final
Post Posted:
 21 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Quote:
_ACCTPROMOTE
added to modules/Your_Account/language as 'define("_ACCTPROMOTE", "You Have Just Been Promoted!");'

_HASPROMOTE
added to modules/Your_Account/language as 'define("_HASPROMOTE","has been promoted.");'  



UPS i wanted to but SVN is down  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
RTC4EVER
Coding Expert
Coding Expert



Joined: 04-Feb-2009
Posts: 923
Location: Zürich
Offline
EVO Version: 2.1.0 Final
Post Posted:
 21 Aug 2009
Reply with quote
Post subject: No icon Re: Beförderter Admin kommt nicht auf admin.php

Lol ReO is allways first  


 
 
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:  
This forum is locked: you cannot post, reply to, or edit topics. This topic is locked: you cannot edit posts or make replies. printer-friendly view
EVO CMS Forum Index -> Fehlermeldungen 2.1.0 RC Time synchronized with the forum server time
 Goto page 1, 2  Next
Page 1 of 2


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum