Search for at
Security Code:
Security Code 
Type Security Code:
EVO CMS Advanced Search
 
 
Recent Topics
Latest Site News << Previous 5  Next 5 >>
Forum Author Replies Last Post
Warning !  Nuke-Evolution im Finale Top5 CMS Awards 2007 News & Informationen Buggi 13 11 Oct 2007
Asmodis View latest post
No icon  German Language Pack News & Informationen Jarl 12 20 Aug 2007
ReOrGaNiSaTiOn View latest post
Idea  Dunkle Websites sparen Strom News & Informationen Spiders 0 20 Aug 2007
Spiders View latest post
Warning !  Chat Scripte News & Informationen chiroptera 2 27 Jul 2007
Donnerstag View latest post
Gniark !  Info zum Willkommen's Bildchen News & Informationen mastermind 3 13 Jul 2007
mastermind View latest post
Recent Topics << Previous 15  Next 15 >>
Forum Author Replies Last Post
No icon  .htacces Erweiterung Tips & Tricks cooper1988 1 02 Aug 2010
RTC4EVER View latest post
No icon  Fehler mit Theme Themes Shark 6 28 Jul 2010
GuestView latest post
solved  Fehler in der Styleverwaltung EVO-CMS 2.x.x Entenmann 3 24 Jul 2010
Entenmann View latest post
No icon  Advertising module not show any string. Fehlermeldungen 2.1.0 RC GANYANCI 1 24 Jul 2010
ReOrGaNiSaTiOn View latest post
No icon  Vwar in 2.1.0 Seite einbinden Allgemeines Shark 6 11 Jul 2010
der-cyberwolf View latest post
solved in Bug Tracker  Bug with the module account when creating an account. Fehlermeldungen 2.1.0 RC Litoon 4 07 Jul 2010
Litoon View latest post
Oh yes !  Wirklich ein reguläres Tor durch Lampard ? ChitChat Guest 15 07 Jul 2010
GuestView latest post
Bad !  admin.php sehr langsam Fehlermeldungen 2.1.0 RC DJBumblebee 17 03 Jul 2010
ReOrGaNiSaTiOn View latest post
No icon  Centerblock teilen Anfragen zu Blöcken tgermanyx 6 01 Jul 2010
ReOrGaNiSaTiOn View latest post
Grrrr !  Michael Jackson lebt !!! Der Versprecher des Jahres ChitChat Guest 2 30 Jun 2010
GuestView latest post
Idea  Wie geil ist das denn? ChitChat Spiders 1 30 Jun 2010
chiroptera View latest post
No icon  Bug with module download Fehlermeldungen 2.1.0 RC Litoon 2 28 Jun 2010
Litoon View latest post
solved in Bug Tracker  Problem in der Forenadministration Fehlermeldungen 2.1.0 RC Reptile2k 9 28 Jun 2010
ReOrGaNiSaTiOn View latest post
solved in Bug Tracker  error with inc./function_evo.php Fehlermeldungen 2.1.0 RC Litoon 5 28 Jun 2010
ReOrGaNiSaTiOn View latest post
solved in Bug Tracker  _LANGCODE doesn't set up correctly in installation step one. Fehlermeldungen 2.1.0 RC GANYANCI 2 26 Jun 2010
ReOrGaNiSaTiOn View latest post
 

 
Problem in der Forenadministration
 
 
This forum is locked: you cannot post, reply to, or edit topics. This topic is locked: you cannot edit posts or make replies. printer-friendly view
View previous topic :: View next topic  
Author Message
Reptile2k
EVO User
EVO User



Joined: 10-Aug-2009
Posts: 47
 
Offline
EVO Version: Nuke-Evo 2.1.0 Rev 2028
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: solved in Bug Tracker Problem in der Forenadministration

Hallo,

hab mir die die aktuellste Version von Evo über SVN besorgt und installiert, verlief alles soweit reibungslos, habe aber ein Problem im Foren Admin Menü.

Wenn ich dort einen Benutzer (in dem Fall mein eigener User Account) editieren möchte, kann ich den echten Namen nicht editieren, die Einträge werden einfach nicht übernommen, gibt auch keine Fehlermeldung. Eigentlich sollte das Feld Echter Name generell nicht leer sein da ich beim Registrieren da schon einen Namen angegeben habe.

Ich kann mir auch keinen Spezialrang fürs Forum einteilen, sobald ich auf "senden" drücke, steht da zwar Profil wurde aktualisiert, wurde aber nicht übernommen.

Woran kann es liegen?

Danke schonmal für eure Hilfe !

EDIT:

Fast hätte ich es vergessen, eine Fehlermeldung hab ich für was anderes gefunden :

wenn ich die Passworthilfe starten will beim registrieren (Hinweise für ein sicheres passwort) kommt die Meldung in einem weißen Fenster :

(Quasi bei :
meineseite.de/language/evo/passhelp_german.php)

ERROR: SERVERPATH AND FILELOCATION ARE DIFFERENT  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Salü,

danke für Deine Fehlermeldungen.

1. die Änderung des realen Namens sowie das ändern des Spezialranges wurden soeben auf php5.3 und php4.4 getestet. Sowohl als angemeldeter User (also angemeldet als User und Admin - Änderung betritt den aktuellen User) als auch ohne Useranmeldung. Beides funktioniert in der Final.

2. Hilfemeldung Passwort: Auch hier wurde auf beiden Testservern gerade noch einmal ein aktueller Test gemacht. Datei wurde bereits geändert und funktioniert in der Final.

3. Echter Name. Verwundert musste ich soeben feststellen, dass auch bei mir bei einem neuen Benutzer der Echte Name nicht in die Datenbank eingetragen wird. Das ist natürlich ein Hammer.
Wird sofort überarbeitet und wird in der Final funktionieren.

Danke ... und teste bitte weiter !!!

Grüße
Reo  


 
 
Back to top
View user's profile Send private message Visit poster's website
Reptile2k
EVO User
EVO User



Joined: 10-Aug-2009
Posts: 47
 
Offline
EVO Version: Nuke-Evo 2.1.0 Rev 2028
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Danke für deine schnelle Antwort ! Werde auf jedenfall weitertesten  Grinsen

Eine Kleinigkeit ist mir da noch aufgefallen, weiß aber nicht ob es so gewollt ist, oder ob es an meinen Seiteneinstellungen liegt. Wenn ich im User Block (Benutzer Info Zentrale) die Cookie Lösch Funktion nutze, bin ich danach immer noch eingeloggt, sowohl als Admin als auch als User. Ein und Ausloggen funktioniert aber tadellos als Admin und User. Stören tut das aufjedenfall nicht, fiel mir jetzt nur deshalb auf weil ich bei der alten Evo Version nach dem Cookie löschen auch direkt ausgeloggt war.  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Salü,

der Fehler bezüglich des realen Namens wurde gefunden und behoben. Wird also in der Final funktionieren.

Cookie-Löschung: Wenn Du Dir Deine Cookies im Browser anschaust, wirst Du feststellen, das in Deiner Version das Cookie löschen noch nicht funktioniert. Das hat mit den geänderten Cookie-Einstellungen zu tun.

Greifst Du eigentlich direkt auf das SVN zu oder lädst Du Dir die gezippte Datei herunter ?

Grüße
Reo  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Geänderte Dateien für Cookieanzeige und Cookielöschung auf Sourceforge SVN geladen.  


 
 
Back to top
View user's profile Send private message Visit poster's website
Reptile2k
EVO User
EVO User



Joined: 10-Aug-2009
Posts: 47
 
Offline
EVO Version: Nuke-Evo 2.1.0 Rev 2028
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Danke fürs uploaden  Grinsen

Quote:
Greifst Du eigentlich direkt auf das SVN zu oder lädst Du Dir die gezippte Datei herunter ?


Also ich habe dieses Turtoise SVN installiert auf meinen Rechner, einmal über das Pogramm gezogen, seitdem hab ich den Nuke Ordner mit einem grünen Haken auf dem Desktop, über rechtsklick wähle ich dann SVN Upate, dann scheint er alles zu aktualisieren. Hoffe ich mach das so richtig?  Embarassed  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 27 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Yepp .... genau so ist es richtig.  


 
 
Back to top
View user's profile Send private message Visit poster's website
GANYANCI
Language Expert
Language Expert



Joined: 24-Jun-2007
Posts: 47
Location: Istanbul / Turkiye
Offline
EVO Version: 2.1.0RC5 Build 2003
Post Posted:
 28 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

This is so easy because wrong define is here.
Quote:
if (realpath(__FILE__) == realpath($_SERVER['SCRIPT_FILENAME'])) {
   exit('ERROR: SERVERPATH AND FILELOCATION ARE DIFFERENT');
}


This is not correct you see.

Correct way is:
Quote:
if (realpath(__FILE__) != realpath($_SERVER['SCRIPT_FILENAME'])) {
   exit('ERROR: SERVERPATH AND FILELOCATION ARE DIFFERENT');
}


All passhelp files (Basic\html\language\evo\passhelp_english.php and other language files) have same bug.

Except passhelp_turkish.php and passhelp_french.php Grinsen  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 28 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

Uuups ... didn't have had a look into (why .. it worked).
Will be complete recoded.  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 28 Jun 2010
Reply with quote
Post subject: No icon Re: Problem in der Forenadministration

OK ... complete recoded and uploaded into SVN.

Greetings
Reo  


 
 
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:  
This forum is locked: you cannot post, reply to, or edit topics. This topic is locked: you cannot edit posts or make replies. printer-friendly view
EVO CMS Forum Index -> Fehlermeldungen 2.1.0 RC Time synchronized with the forum server time
 
Page 1 of 1


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum