Search for at
Security Code:
Security Code 
Type Security Code:
EVO CMS Advanced Search
 
 
Recent Topics
Latest Site News   Next 5 >>
Forum Author Replies Last Post
fixed  Frage nach JavaScript aktiv oder nicht? Fixes & Patches 2.1.x Guest 8 30 Mar 2013
GuestView latest post
fixed  [FIX 2.1.0] Lost Password Fixes & Patches 2.1.x chiroptera 0 21 Feb 2012
chiroptera View latest post
fixed  [FIX 2.1.0] Forums ACP - FAQ Admin Fixes & Patches 2.1.x chiroptera 1 27 Oct 2011
chiroptera View latest post
fixed  [FIX 2.1.0] Forums Attachment Image Resize Fixes & Patches 2.1.x chiroptera 0 26 Oct 2011
chiroptera View latest post
Important  [INFO] evo-mods service started News & Informationen chiroptera 2 24 Oct 2011
chiroptera View latest post
Recent Topics << Previous 15  Next 15 >>
Forum Author Replies Last Post
No icon  Bug when i want update a file on module download. Fehlermeldungen 2.1.0 RC Litoon 10 20 Aug 2010
RTC4EVER View latest post
solved  Update 1.2.0 -> 2.1.0RC5 Fragen & Hilfe zur Installation/Upgrade 2.1.x tgermanyx 36 20 Aug 2010
chiroptera View latest post
Hehehe !  TeamSpeak Viewer Alpha Version Module DJBumblebee 5 19 Aug 2010
Beun12 View latest post
solved  Frage zur ersten Adminanmeldung nach neuer Installation Fragen & Hilfe zur Installation/Upgrade 2.1.x der-cyberwolf 2 17 Aug 2010
RTC4EVER View latest post
solved  Seiten logo Allgemeines tgermanyx 23 16 Aug 2010
chiroptera View latest post
solved in Bug Tracker  Umlaute Evo 2.1.0 RC1 Support German Community Melina 25 16 Aug 2010
Anna View latest post
solved  Wie kann ich die Ansicht der Foren im Index ändern ? Tips & Tricks Anna 5 14 Aug 2010
Anna View latest post
solved in Bug Tracker  Wieder Probleme mit den Themes Fehlermeldungen 2.1.0 RC Entenmann 15 14 Aug 2010
Anna View latest post
Roleplay  Ein Evo Theme von Tabellen Layout zum tabellenfreien Layout! Themes Spiders 40 13 Aug 2010
chiroptera View latest post
solved in Bug Tracker  Problem mit .htaccess und gesperrtem IP Bereich. Fehlermeldungen 2.1.0 RC Entenmann 1 13 Aug 2010
ReOrGaNiSaTiOn View latest post
No icon  Onlineanzeige Gäste Fehlermeldungen 2.1.0 RC Entenmann 4 12 Aug 2010
ReOrGaNiSaTiOn View latest post
No icon  Sentinel Fehlermeldungen 2.1.0 RC Entenmann 11 12 Aug 2010
ReOrGaNiSaTiOn View latest post
solved in Bug Tracker  Neues Modul wird spät erkannt EVO-CMS 2.x.x DJBumblebee 6 12 Aug 2010
ReOrGaNiSaTiOn View latest post
solved in Bug Tracker  Themenvorschau Endlosschleife Fehlermeldungen 2.1.0 RC Entenmann 3 12 Aug 2010
ReOrGaNiSaTiOn View latest post
solved in Bug Tracker  Bug with profile and Private message Fehlermeldungen 2.1.0 RC Litoon 2 11 Aug 2010
ReOrGaNiSaTiOn View latest post
 

 
Neues Modul wird spät erkannt
 
 
Post new topic Reply to topic printer-friendly view
View previous topic :: View next topic  
Author Message
DJBumblebee
EVO User
EVO User



Joined: 26-Aug-2009
Posts: 103
 
Offline
EVO Version: 2.1.0
Post Posted:
 11 Aug 2010
Reply with quote
Post subject: solved in Bug Tracker Neues Modul wird spät erkannt

Hallo zusammen,

kleien Frage wenn ich ein neues Modul hochlade dauert es ewig bis dies endlich in der Modulverwaltung auftaucht früher war das mal schneller woher kommt das und kann ich das beeinflussen den auf der Webseite wo ich Module entwickle nervt mich das total ich muss das neue modul immmer mannuel in die DB eintragen und dann noch den cache leeren.  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 11 Aug 2010
Reply with quote
Post subject: No icon Re: Neues Modul wird spät erkannt

Erledigt.

Es werden nun alle mit einer Moduländerung (neu, gelöscht oder geändert) betroffenen Cache-Dateien gelöscht.
In den diversen SVN verfügbar.  


 
 
Back to top
View user's profile Send private message Visit poster's website
DJBumblebee
EVO User
EVO User



Joined: 26-Aug-2009
Posts: 103
 
Offline
EVO Version: 2.1.0
Post Posted:
 11 Aug 2010
Reply with quote
Post subject: No icon Re: Neues Modul wird spät erkannt

Ups dachte das ist einstellungs sache lol na schön bei der Verbesserung so zu helfen smile  


 
 
Back to top
View user's profile Send private message Visit poster's website
DJBumblebee
EVO User
EVO User



Joined: 26-Aug-2009
Posts: 103
 
Offline
EVO Version: 2.1.0
Post Posted:
 12 Aug 2010
Reply with quote
Post subject: No icon Re: Neues Modul wird spät erkannt

Hi ich habe nun die svn Rev 186 online aber das Modul wird nach wie vor nicht unter Modulen angezeigt? Habe auch mal funktionierende Module unter anderem Namen als Kopie hoch geladen und auch die werden nicht erkannt auch nach mehr als 12 Stunden und x mal cache leeren nicht. mache ich was falsch oder ist das immer noch ein bug?  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 12 Aug 2010
Reply with quote
Post subject: No icon Re: Neues Modul wird spät erkannt

Öhm ... das heißt Du hast ein anderes Problem.

Sobald die Evo Administration aufgerufen wird, wird ein Check gemacht (Funktion: update_modules() in functions_evo.php).

Dort wird geprüft, ob es ein neues Modulverzeichnis gibt. Wenn ja, wird der Modulname in die Datenbank eingepflegt.
Somit kommt gleich die 1. Fragen:
1. Ist ein Datensatz für das Modul in der Datenbank ?
2. Gibt es evt. eine Fehlermeldung (SQL) in der Administration ?

Danach wird geprüft, ob es Module in der Datenbank gibt, die gelöscht wurden (Verzeichnis nicht mehr vorhanden). Wenn ja, lösche Datensatz aus der Datenbank.

Aktualisiere die Cache.

Das ist alles.

Ich kann mir nur noch vorstellen, dass zwar der Datensatz in die Datenbank aufgenommen wurde, jedoch keine case.php und links.php für das Modul vorhanden ist und damit das Modul nicht im Modulverzeichnis angezeigt wird.

Wenn Du Module entwickelst, hast Du in der config.php hoffentlich die Debug-Einstellung auf 'FULL' (in Anführungszeichen) gesetzt ? Dann werden sämtliche E-Notice und E-Warnings ausgegeben.

Ich habe nach der Überarbeitung sowohl unter php5.3 als auch unter php4.4.9 Module eingebunden (also einfach das Modulverzeichnis angelegt) und das betreffende Modul war sofort verfügbar.

Wenn Du nicht weiter kommst, dann kannst Du mir Deine Zugriffsdaten (FTP und Admin) per PN senden, dann kann ich das mal direkt debuggen.

Grüße
Reo  


 
 
Back to top
View user's profile Send private message Visit poster's website
DJBumblebee
EVO User
EVO User



Joined: 26-Aug-2009
Posts: 103
 
Offline
EVO Version: 2.1.0
Post Posted:
 12 Aug 2010
Reply with quote
Post subject: No icon Re: Neues Modul wird spät erkannt

Schön das du hie rmal die genaue funktion erklärt hast da ist mir der fehler auf gefallen ich bin immer in die Modulverwaltung über den Link im Menü und dann passiert nix aber als ich die Admin hauptseite aufgerufen habe wars drin wäre vileich nicht schlecht die funktion nochmal in der Modulverwaltung ablaufen zu lassen.  


 
 
Back to top
View user's profile Send private message Visit poster's website
ReOrGaNiSaTiOn
EVO World Team
EVO World Team



Joined: 03-Jan-2006
Posts: 11742
Location: Als Schwabe in Sachsen-Anhalt
Offline
EVO Version: - Developer Edition -
Post Posted:
 12 Aug 2010
Reply with quote
Post subject: No icon Re: Neues Modul wird spät erkannt

... dein Wunsch war mir Befehl ... und schon im SVN.  


 
 
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:  
Post new topic Reply to topic printer-friendly view
EVO CMS Forum Index -> EVO-CMS 2.x.x Time synchronized with the forum server time
 
Page 1 of 1


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum